Problem
- I need to confirm my Miami parent account, but my confirmation link has expired
- I need to confirm my Miami family account, but my confirmation link has expired
Cause
- The link created and sent to a parent to verify and complete account set up is only good for a set amount of time — you have exceeded the time allowed to respond, and the link has expired
Resolution
To receive a new confirmation link for your parent or family account, follow this procedure:
- Go to the Family Member Password Reset page
- Enter the email address your student added for you in the E-Mail Address: field
- Select Submit
- A new confirmation email will be sent to your account
Note
- As of March 28th 2024, family account holders can process self service password recoveries for their accounts. This process will generate an email or SMS with a one time code to recover the user's password. This can be accomplished using the steps found at MiamiOH.edu/Password
User
- Miami University parent or family member
System
- 284774: Student Information for Families
- Identity and Access Management