Assistance needed to access a new account / Miami Email

Problem

  • I need assistance in troubleshooting and accessing my new Miami email account
  • I received the error: Invalid Email — We are unable to process your request at this time, please try again later

Cause

  • Your Miami email account has not yet been created
    • In periods of high demand, it may take a few days for a new account to be created

Resolution

  1. Accept Google's Terms of Service to activate your Miami email account
  2. If you receive the same error, wait a few hours and try logging in again
  3. Follow these KB instructions to clear your browser cache and data
  4. If the issue persists, contact IT Help by phone at 513-529-7900 or by live chat at MiamiOH.edu/ITChat to check on your account status

System

  • 10262: Google Mail (email e-mail) 
  • Miami Email

 


For internal use