Remove malware from an iOS device

Issue/Question

  • My iPhone or iPad is blocked from the network due to malware or a virus. How can I fix it?

Environment

  • 10684: DHCP
  • Personally-owned Device
  • iOS

Cause 

  • You have been notified by IT Services that a malicious application has infected your iOS device

Resolution

Remove the malicious app

  1. Long-press on the app that must be removed
  2. When an X appears over the app, tap the X
  3. Take the device to MiTech to verify that it is clean

 

Reset your device to factory settings

If you are blocked again after MiTech has verified that your device is clean and your initial block has been removed, reset your device to factory settings:

  1. Tap Settings
  2. Tap General
  3. Tap Erase All Content and Settings
  4. Tap Confirm
    • Note: This will erase all user data and restore the device to its default state
  5. Return the device to MiTech to verify that it is clean

 

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Details

Article ID: 26394
Created
Sat 3/4/17 3:06 PM
Modified
Tue 4/2/19 2:52 PM
Can you resolve this issue yourself?
Can the end-user resolve the issue using the instructions given?
Or does the end-user need to request assistance from Miami UIT, a client office, or a vendor?
Yes! This is self-service with a smile.