Miami Email / Assistance needed to access a new account

Objective

  • To provide assistance in troubleshooting and accessing your new Miami email account when:
    • You receive the error: Invalid Email — We are unable to process your request at this time, please try again later

Environment

  • 10262: Google Mail (email e-mail) 
    • Miami Email
    • New Account

Cause

  • Your Miami email account has not yet been created
    • In periods of high demand, it may take a few days for a new account to be created

Resolution

  1. Accept Google's Terms of Service to activate your Miami email account
  2. If you receive the same error, wait a few hours and try logging in again
  3. Follow these KB instructions to clear your browser cache and data
  4. If the issue persists, contact IT Help by phone at 513-529-7900 or by live chat at MiamiOH.edu/ITChat to check on your account status

 


For internal use

 

Details

Article ID: 30868
Created
Fri 5/26/17 9:55 AM
Modified
Mon 11/27/23 10:00 AM
Can you resolve this issue yourself?
Yes! This is self-service with a smile.
Supported Office or Community
University Community of Students, Staff, and Faculty