Print
Print:
Body
Related Articles
Duo / Update browser when prompted during authentication
Body
Objective
To provide instructions on how to update a web browser
Update a Chrome, Firefox, Internet Explorer, Edge, Safari web browser
Environment
312306: Duo Security Two-factor Authentication
Chrome
Firefox
Internet Explorer
Safari
Windows computer
macOS computer
Android device
iOS device
iPhone
iPad
Cause
When you authenticate with Duo, the authentication system will check your web browser and — if you're using an outdated version — prompt you to update it to the latest, most secure version
Resolution
When prompted to update your browser, you can ignore the prompt for a limited time by simply continuing
Or you can update your browser by clicking the
Let's update it
button — it's fast and easy to do!
Update your Chrome browser
In your browser, click the
More
icon (three vertical dots in the upper right corner of the browser)
Click
Help
Click
About Google Chrome
Follow the prompts
Update Chrome on your Android device
On your Android phone or tablet, open the Play Store app
At the top left, tap
Menu
and select
My apps & games.
Apps with available updates are listed under
Updates
Under
Updates
, look for
Chrome
If Chrome is listed, tap
Update
Update Chrome on your iPhone or iPad
On your iPhone or iPad, open the App Store
At the bottom, tap
Updates
In the pending updates, look for
Chrome
If Chrome is listed, tap
Update
to install
If prompted, enter your Apple ID password
The updates will download and install
Update your Firefox browser
In your browser, click
Firefox
in the menu bar and select
About Firefox
When the
About Firefox
window opens, Firefox will check for updates and download them automatically
When prompted, click the
Restart to update Firefox
button to install the latest version
Update Firefox on your Android device
Open Google Play on your device and tap on the menu at the top left corner of the screen
Tap on
My Apps
to see your list of installed apps
Firefox for Android will appear in the Updates list, if there is an update available
Tap on the
Update
button
Update Firefox on your iPhone or iPad
On your iPhone or iPad, open the App Store
At the bottom, tap
Updates
In the pending updates, look for Firefox
If Firefox is listed, tap
Update
to install
If prompted, enter your Apple ID password
The updates will download and install
Update your Internet Explorer browser
Go to Microsoft's Internet Explorer download site
Select the most recent version of Internet Explorer
Click the
Download
button
When the download is complete, click
Run
to start the installation
Update your Safari browser
Click the Apple menu
icon and select
Software Update...
In the Software Update window, check the
Safari Update
box
We recommend that you select all software listed for update
Click the
Install X Items
button at the bottom of the window
Enter your computer's administrator password, if prompted
Wait for the software update to be completed
Update Safari on your iPhone or iPad
On your iPhone or iPad, open
Settings
Under
General
, select
Software Update
Notes
For Google Chrome, Firefox, Internet Explorer, Microsoft Edge, or Safari support,
visit these up-to-date vendor sites for everything you want to know about these popular browsers
Browse the Google Chrome Help site
Browse the Mozilla Firefox Support site
Browse the Microsoft Edge Support site
Browse the Microsoft Internet Explorer Support site
Browse the Apple Safari Support site
Details
Details
Article ID:
61172
Created
Fri 8/24/18 12:24 PM
Modified
Mon 4/29/24 8:44 AM
Can you resolve this issue yourself?
Yes! This is self-service with a smile.
Related Articles
Related Articles (2)
Browser / Download and install
Miami Account / Authentication Interrupt prompt