Resolve display of missing uploaded or embedded course images / Canvas
Body
Problem
- Uploaded images are not showing for a page in my Canvas course
- Embedded images that were once displayed no longer appear
Cause
- If the images were uploaded to Canvas, this is most likely a temporary issue that can be resolved by clearing browser cache and cookies or checking back later
- If the image is hosted outside of Canvas, the embed code may be incorrect or the owner of the image may need to adjust permissions
Resolution
- Images uploaded to Canvas: Follow these instructions on clearing your browser cache and check back later
- Embedded images: The instructor will need to ensure that the embed code for the image is correct and that the owner of the image has permitted the image to be viewed by anyone
Notes
- Visit the Canvas Status Dashboard to check performance information for Canvas services
- Instructure provides up-to-date documentation and instructions for Canvas
User
- Canvas Instructor, Student
System
Details
Details
Article ID:
45560
Created
Tue 1/2/18 1:40 AM
Modified
Wed 5/6/26 3:22 PM